re = /([a-z0-9_-]+):(?:\s?(\S+))?/m
str = 'link: http://google.com/ nospace:yes text: hello world foo: tesat: baz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end