using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(?<=\\)([^_]+)_([^_]+)";
string input = @"C:\Users\Robot\Documents\UiPath\ExtractedFolder\123456_78912345_Test_File_2020.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}