$re = '/.*(?<=\\\\)([^_]+)_([^_]+)/m';
$str = 'C:\\Users\\Robot\\Documents\\UiPath\\ExtractedFolder\\123456_78912345_Test_File_2020.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);