#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[78]([-* *\(*-*\(*\)*\d]{10})"
Local $sString = " '84951234567', '+74951234567', '8-495-1-234-567', " & @CRLF & _
" ' 8 (8122) 56-56-56', '8-911-1234567', '8 (911) 12 345 67', " & @CRLF & _
" '8-911 12 345 67', '8 (911) - 123 - 45 - 67', '+ 7 999 123 4567', " & @CRLF & _
" '8 ( 999 ) 1234567', '8 999 123 4567'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")