import re
regex = re.compile(r"[78]([-* *\(*-*\(*\)*\d]{10})")
test_str = (" '84951234567', '+74951234567', '8-495-1-234-567', \n"
" ' 8 (8122) 56-56-56', '8-911-1234567', '8 (911) 12 345 67', \n"
" '8-911 12 345 67', '8 (911) - 123 - 45 - 67', '+ 7 999 123 4567', \n"
" '8 ( 999 ) 1234567', '8 999 123 4567'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")