const regex = /\w{2}-\w{3}\d{5}_\d{10}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w{2}-\\w{3}\\d{5}_\\d{10}', 'g')
const str = `pp-gfg76482_8498680983`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}