package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([\w\.\'\-\+]+\@(?:[a-z0-9\.\-\p{L}]+\.)+(?:[a-zA-Z0-9\-\p{L}]{2,24}))`)
var str = `<p>Тест@домен.ком</p>
Тест@домен.ком
test@domain.com
γλώσσα@τομέας.com
<p>моят-тестов@пример.bg</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}