// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ui)([\w\.\'\-\+]+\@(?:[a-z0-9\.\-\p{L}]+\.)+(?:[a-zA-Z0-9\-\p{L}]{2,24}))").unwrap();
let string = "<p>Тест@домен.ком</p>
Тест@домен.ком
test@domain.com
γλώσσα@τομέας.com
<p>моят-тестов@пример.bg</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}