import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+\\s+\\d+\\s+\\d+:\\d+:\\d+\\s+[^\\s]+\\s\\w+\\s+\\d+\\s+\\d+:\\d+:\\d+\\s+([^\\s]+)";
final String string = "Sep 20 11:13:18 1x.xx.xx.1xx0 Sep 20 11:13:15 ac.dc1.buttercomom.com ASM:\"MONEYPAK_WEBAPP\",\"MONEYPAK_CLASS\",\"Blocked\",\"Attack signature detected\",\"xxxx4520\",,\"GET /Content/Images/ixx_logo01_module02.gif HTTP/1.1\\r\\nHost: www.xxxxk.com\\r\\nUser-Agent: sxx/1.0x6264944] UP.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}