// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\w+\s+\d+\s+\d+:\d+:\d+\s+[^\s]+\s\w+\s+\d+\s+\d+:\d+:\d+\s+([^\s]+)").unwrap();
let string = "Sep 20 11:13:18 1x.xx.xx.1xx0 Sep 20 11:13:15 ac.dc1.buttercomom.com ASM:\"MONEYPAK_WEBAPP\",\"MONEYPAK_CLASS\",\"Blocked\",\"Attack signature detected\",\"xxxx4520\",,\"GET /Content/Images/ixx_logo01_module02.gif HTTP/1.1\\r\\nHost: www.xxxxk.com\\r\\nUser-Agent: sxx/1.0x6264944] UP.";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}