import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d{12}\\b.+?(?=\\b\\d{12}\\b|$)";
final String string = "LOREM IPSUM LOR IPSUM DDDDDDDDD FG SSSSS NUMBER 106/03/2019 LOREMFG OF LOREMIPSUMF LOREM OPFRTE ERTIO LOREMIPS LOREMIOS 05/30/2019 DERTE TH LOREM (LWA LTD)------------------------------------------------------------------------------------------------------------------------------------011111111111 CDGH, LGF ADF : 203 HYT *LOREM IPSUM / LOREM IPSUM* COUNTY : GTYH CHIDGER L. IPSUM THJ. DATE: 07/21/2000 LOREM IPSUM DOLOT & LOREM IPSUM 768 LOREM IPSUM, 67TH LOREM IPSUM IPSUM. DTEA: NIGER, GA 12345 LOREM IPSUM DOLOT 97 LOREM IPSUM DOLOT, KY 35678-8765 011111111111 CDGH, LGF ADF : 203 HYT *LOREM IPSUM / LOREM IPSUM* COUNTY : GTYH CHIDGER L. IPSUM THJ. DATE: 07/21/2000 LOREM IPSUM DOLOT & LOREM IPSUM 768 LOREM IPSUM, 67TH LOREM IPSUM IPSUM. DTEA: NIGER, GA 12345 LOREM IPSUM DOLOT 97 LOREM IPSUM DOLOT, KY 35678-8765 011111111111 CDGH, LGF ADF : 203 HYT *LOREM IPSUM / LOREM IPSUM* COUNTY : GTYH CHIDGER L. IPSUM THJ. DATE: 07/21/2000 LOREM IPSUM DOLOT & LOREM IPSUM 768 LOREM IPSUM, 67TH LOREM IPSUM IPSUM. DTEA: NIGER, GA 12345 LOREM IPSUM DOLOT 97 LOREM IPSUM DOLOT, KY 35678-8765 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}