const regex = /\b\d{12}\b.+?(?=\b\d{12}\b|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{12}\\b.+?(?=\\b\\d{12}\\b|$)', 'gm')
const str = `LOREM IPSUM LOR IPSUM DDDDDDDDD FG SSSSS NUMBER 106/03/2019 LOREMFG OF LOREMIPSUMF LOREM OPFRTE ERTIO LOREMIPS LOREMIOS 05/30/2019 DERTE TH LOREM (LWA LTD)------------------------------------------------------------------------------------------------------------------------------------011111111111 CDGH, LGF ADF : 203 HYT *LOREM IPSUM / LOREM IPSUM* COUNTY : GTYH CHIDGER L. IPSUM THJ. DATE: 07/21/2000 LOREM IPSUM DOLOT & LOREM IPSUM 768 LOREM IPSUM, 67TH LOREM IPSUM IPSUM. DTEA: NIGER, GA 12345 LOREM IPSUM DOLOT 97 LOREM IPSUM DOLOT, KY 35678-8765 011111111111 CDGH, LGF ADF : 203 HYT *LOREM IPSUM / LOREM IPSUM* COUNTY : GTYH CHIDGER L. IPSUM THJ. DATE: 07/21/2000 LOREM IPSUM DOLOT & LOREM IPSUM 768 LOREM IPSUM, 67TH LOREM IPSUM IPSUM. DTEA: NIGER, GA 12345 LOREM IPSUM DOLOT 97 LOREM IPSUM DOLOT, KY 35678-8765 011111111111 CDGH, LGF ADF : 203 HYT *LOREM IPSUM / LOREM IPSUM* COUNTY : GTYH CHIDGER L. IPSUM THJ. DATE: 07/21/2000 LOREM IPSUM DOLOT & LOREM IPSUM 768 LOREM IPSUM, 67TH LOREM IPSUM IPSUM. DTEA: NIGER, GA 12345 LOREM IPSUM DOLOT 97 LOREM IPSUM DOLOT, KY 35678-8765 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}