import re
regex = re.compile(r"A(?!.*[A-Z]{2})+?.*(\d+)", flags=re.MULTILINE)
test_str = ("A bcd 1 should match\n"
"Abcd1 should match\n"
"A bcd should not match because there is no number\n"
"A bCD 1 should not match because there is capital C between the A and the number \n"
"A bcd 1 B should match because `1` is before the B\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")