re = /A(?!.*[A-Z]{2})+?.*(\d+)/m
str = 'A bcd 1 should match
Abcd1 should match
A bcd should not match because there is no number
A bCD 1 should not match because there is capital C between the A and the number
A bcd 1 B should match because `1` is before the B
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end