using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?P<protocol>file):\/\/)?(?P<path>.+?)(?:\.git)?\/?$";
string input = @"file:///path/to/git/repo.git/
file:///path/to/git/repo.git
file:///path/to/git/repo
file://path/to/git/repo
/path/to/git/repo
path/to/git/repo";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}