$re = '/^(?:(?P<protocol>file):\/\/)?(?P<path>.+?)(?:\.git)?\/?$/m';
$str = 'file:///path/to/git/repo.git/
file:///path/to/git/repo.git
file:///path/to/git/repo
file://path/to/git/repo
/path/to/git/repo
path/to/git/repo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);