#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^Dealer:\xA0"
Local $sString = "Dealer: callawaykid wins 428 chips" & @CRLF & _
"Dealer: ** Hand [ 1288159259 ] started **" & @CRLF & _
"Dealer: Dealt to board: [ 4h Qh 2c ]" & @CRLF & _
"Dealer: Dealt to board: [ 8h ]" & @CRLF & _
"Dealer: Dealt to board: [ 6d ]" & @CRLF & _
"Dealer: Showdown: Main pot, 380 chips" & @CRLF & _
"Dealer: centraliaxxx mucks" & @CRLF & _
"Dealer: centraliaxxx wins 380 chips" & @CRLF & _
"Dealer: ** Hand [ 1288159639 ] started **"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)