const regex = /\.[^{\s]*(?=\s*{)(?!(?:(?!\/\*)[\s\S])*\*\/)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.[^{\\s]*(?=\\s*{)(?!(?:(?!\\\/\\*)[\\s\\S])*\\*\\\/)', 'g')
const str = `.text-center { text-align: center; }
table.simple{background:#fff;}.bg-white{background:#fff;}
table
.simple
{background:#fff;}
.bg-white{background:#fff;}
/*# sourceMappingURL=style.css.map {}*/
/*
Example comment file.css
*/`;
const subst = `.a`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);