$re = '/<a\sid=\"link\"\shref=\"(.*?)\"/m';
$str = '<a id="link" href="link.php">link<a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);