re = /<a\sid=\"link\"\shref=\"(.*?)\"/m
str = '<a id="link" href="link.php">link<a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end