using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a href=""(https?:\/\/(?![^\/""]*bing)[^""]+)""";
string input = @"a href=""https://www.bing.com/aclk""
a href=""https://www.ring.com/aclk""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}