$re = '/a href="(https?:\/\/(?![^\/"]*bing)[^"]+)"/m';
$str = 'a href="https://www.bing.com/aclk"
a href="https://www.ring.com/aclk"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);