#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(\w+\[\d+]\[\w+]\[)(\d+)(?=])"
Local $sString = "soundConfig[0][songs][1][html]"
Local $sSubst = "$1REPLACEMENT"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)