$re = '/^(\w+\[\d+]\[\w+]\[)(\d+)(?=])/';
$str = 'soundConfig[0][songs][1][html]';
$subst = "$1REPLACEMENT";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;