#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([A-Z0-9-]+)\.txt:NAME:\s\"module\s\w+\s([0-9/]+)\",\sDESCR:\s\"(.+)\""
Local $sString = "RMAGPGE-PGBP01-01.txt:NAME: "module R0", DESCR: "ASR 900 Route Switch Processor 2, Base Scale, 128Gbps"" & @CRLF & _
"RMAGPGE-PGIG01-01.txt:NAME: "module R0", DESCR: "ASR 903 Route Switch Processor 1, Base Scale, 55Gbps"" & @CRLF & _
"RMAGPGE-PGIG01-01.txt:NAME: "module R1", DESCR: "ASR 903 Route Switch Processor 1, Base Scale, 55Gbps"" & @CRLF & _
"RMAGPUI-PLIG01-01.txt:NAME: "module R0", DESCR: "ASR 900 Route Switch Processor 2, Base Scale, 128Gbps"" & @CRLF & _
"RMAGPUI-PLIG01-01.txt:NAME: "module R1", DESCR: "ASR 900 Route Switch Processor 2, Base Scale, 128Gbps"" & @CRLF & _
"RMAGPUI-PLMD00-01.txt:NAME: "module R0", DESCR: "ASR 900 Route Switch Processor 2, Base Scale, 128Gbps"" & @CRLF & _
"RMAGPUI-PLMD00-01.txt:NAME: "module R1", DESCR: "ASR 900 Route Switch Processor 2, Base Scale, 128Gbps"" & @CRLF & _
"RMAGPUI-PLMI00-01.txt:NAME: "module R0", DESCR: "ASR 900 Route Switch Processor 2, Base Scale, 128Gbps"" & @CRLF & _
"RMAGPUI-PLMI00-01.txt:NAME: "module R1", DESCR: "ASR 900 Route Switch Processor 2, Base Scale, 128Gbps"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module 0/RSP0/CPU0", DESCR: "ASR9K Route Switch Processor with 440G/slot Fabric and 12GB"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module 0/RSP1/CPU0", DESCR: "ASR9K Route Switch Processor with 440G/slot Fabric and 12GB"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module 0/0/CPU0", DESCR: "160G Modular Linecard, Service Edge Optimized"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module 0/0/0", DESCR: "ASR 9000 8-port 10GE Modular Port Adapter"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/0/0/0", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/0/0/1", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/0/0/2", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/0/0/3", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/0/0/4", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/0/0/5", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/0/0/6", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/0/0/7", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module 0/0/1", DESCR: "ASR 9000 8-port 10GE Modular Port Adapter"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/0/1/2", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/0/1/3", DESCR: "10GBASE-ZR SFP+, SMF 80km"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/0/1/4", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/0/1/5", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/0/1/6", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/0/1/7", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module 0/1/CPU0", DESCR: "160G Modular Linecard, Service Edge Optimized"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module 0/1/0", DESCR: "ASR 9000 8-port 10GE Modular Port Adapter"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/1/0/0", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/1/0/1", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/1/0/2", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/1/0/3", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/1/0/4", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/1/0/5", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/1/0/6", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/1/0/7", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module 0/1/1", DESCR: "ASR 9000 8-port 10GE Modular Port Adapter"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/1/1/2", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/1/1/3", DESCR: "10GBASE-ZR SFP+, SMF 80km"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/1/1/4", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/1/1/5", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/1/1/6", DESCR: "10GBASE-ZR SFP+, SMF 80km"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/1/1/7", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module 0/2/CPU0", DESCR: "160G Modular Linecard, Service Edge Optimized"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module 0/2/0", DESCR: "ASR 9000 8-port 10GE Modular Port Adapter"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/2/0/0", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/2/0/1", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/2/0/2", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/2/0/3", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/2/0/4", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/2/0/5", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/2/0/6", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/2/0/7", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module 0/3/CPU0", DESCR: "160G Modular Linecard, Service Edge Optimized"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module 0/3/0", DESCR: "ASR 9000 8-port 10GE Modular Port Adapter"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/3/0/0", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/3/0/1", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/3/0/2", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/3/0/3", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/3/0/4", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/3/0/5", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/3/0/6", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-CGD01-01.txt:NAME: "module mau 0/3/0/7", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module 0/RSP0/CPU0", DESCR: "ASR9K Route Switch Processor with 440G/slot Fabric and 12GB"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module 0/RSP1/CPU0", DESCR: "ASR9K Route Switch Processor with 440G/slot Fabric and 12GB"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module 0/0/CPU0", DESCR: "160G Modular Linecard, Service Edge Optimized"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module 0/0/0", DESCR: "ASR 9000 8-port 10GE Modular Port Adapter"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/0/0", DESCR: "10GBASE-ZR SFP+, SMF 80km"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/0/1", DESCR: "10GBASE-ZR SFP+, SMF 80km"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/0/2", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/0/3", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/0/4", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/0/5", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/0/6", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/0/7", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module 0/0/1", DESCR: "ASR 9000 8-port 10GE Modular Port Adapter"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/1/0", DESCR: "10GBASE-ZR SFP+, SMF 80km"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/1/1", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/1/2", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/1/3", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/1/4", DESCR: "10GBASE-ZR SFP+, SMF 80km"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/1/5", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/1/6", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/0/1/7", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module 0/1/CPU0", DESCR: "160G Modular Linecard, Service Edge Optimized"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module 0/1/0", DESCR: "ASR 9000 8-port 10GE Modular Port Adapter"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/0/0", DESCR: "10GBASE-ZR SFP+, SMF 80km"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/0/1", DESCR: "10GBASE-ZR SFP+, SMF 80km"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/0/2", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/0/3", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/0/4", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/0/5", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/0/6", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/0/7", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module 0/1/1", DESCR: "ASR 9000 8-port 10GE Modular Port Adapter"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/1/0", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/1/1", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/1/2", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/1/3", DESCR: "10GBASE-ZR SFP+, SMF 80km"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/1/4", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/1/5", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/1/6", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-GDL01-01.txt:NAME: "module mau 0/1/1/7", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module 0/RSP0/CPU0", DESCR: "ASR9K Route Switch Processor with 440G/slot Fabric and 12GB"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module 0/RSP1/CPU0", DESCR: "ASR9K Route Switch Processor with 440G/slot Fabric and 12GB"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module 0/0/CPU0", DESCR: "160G Modular Linecard, Service Edge Optimized"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module 0/0/0", DESCR: "ASR 9000 8-port 10GE Modular Port Adapter"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/0/0/0", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/0/0/1", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/0/0/2", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/0/0/3", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/0/0/4", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/0/0/5", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/0/0/6", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/0/0/7", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module 0/0/1", DESCR: "ASR 9000 8-port 10GE Modular Port Adapter"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/0/1/0", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/0/1/2", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/0/1/3", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/0/1/4", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/0/1/5", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/0/1/6", DESCR: "10GBASE-ER 1550nm SMF 40KM"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/0/1/7", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module 0/1/CPU0", DESCR: "160G Modular Linecard, Service Edge Optimized"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module 0/1/0", DESCR: "ASR 9000 8-port 10GE Modular Port Adapter"" & @CRLF & _
"RMAGRJO-MRT01-01.txt:NAME: "module mau 0/1/0/0", DESCR: "10GBASE-LR SFP+ Module for SMF"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")