import re
regex = re.compile(r"([A-Z0-9-]+)\.txt:NAME:\s\"module\s\w+\s([0-9/]+)\",\sDESCR:\s\"(.+)\"")
test_str = ("RMAGPGE-PGBP01-01.txt:NAME: \"module R0\", DESCR: \"ASR 900 Route Switch Processor 2, Base Scale, 128Gbps\"\n"
"RMAGPGE-PGIG01-01.txt:NAME: \"module R0\", DESCR: \"ASR 903 Route Switch Processor 1, Base Scale, 55Gbps\"\n"
"RMAGPGE-PGIG01-01.txt:NAME: \"module R1\", DESCR: \"ASR 903 Route Switch Processor 1, Base Scale, 55Gbps\"\n"
"RMAGPUI-PLIG01-01.txt:NAME: \"module R0\", DESCR: \"ASR 900 Route Switch Processor 2, Base Scale, 128Gbps\"\n"
"RMAGPUI-PLIG01-01.txt:NAME: \"module R1\", DESCR: \"ASR 900 Route Switch Processor 2, Base Scale, 128Gbps\"\n"
"RMAGPUI-PLMD00-01.txt:NAME: \"module R0\", DESCR: \"ASR 900 Route Switch Processor 2, Base Scale, 128Gbps\"\n"
"RMAGPUI-PLMD00-01.txt:NAME: \"module R1\", DESCR: \"ASR 900 Route Switch Processor 2, Base Scale, 128Gbps\"\n"
"RMAGPUI-PLMI00-01.txt:NAME: \"module R0\", DESCR: \"ASR 900 Route Switch Processor 2, Base Scale, 128Gbps\"\n"
"RMAGPUI-PLMI00-01.txt:NAME: \"module R1\", DESCR: \"ASR 900 Route Switch Processor 2, Base Scale, 128Gbps\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module 0/RSP0/CPU0\", DESCR: \"ASR9K Route Switch Processor with 440G/slot Fabric and 12GB\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module 0/RSP1/CPU0\", DESCR: \"ASR9K Route Switch Processor with 440G/slot Fabric and 12GB\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module 0/0/CPU0\", DESCR: \"160G Modular Linecard, Service Edge Optimized\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module 0/0/0\", DESCR: \"ASR 9000 8-port 10GE Modular Port Adapter\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/0/0/0\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/0/0/1\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/0/0/2\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/0/0/3\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/0/0/4\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/0/0/5\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/0/0/6\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/0/0/7\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module 0/0/1\", DESCR: \"ASR 9000 8-port 10GE Modular Port Adapter\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/0/1/2\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/0/1/3\", DESCR: \"10GBASE-ZR SFP+, SMF 80km\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/0/1/4\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/0/1/5\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/0/1/6\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/0/1/7\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module 0/1/CPU0\", DESCR: \"160G Modular Linecard, Service Edge Optimized\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module 0/1/0\", DESCR: \"ASR 9000 8-port 10GE Modular Port Adapter\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/1/0/0\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/1/0/1\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/1/0/2\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/1/0/3\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/1/0/4\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/1/0/5\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/1/0/6\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/1/0/7\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module 0/1/1\", DESCR: \"ASR 9000 8-port 10GE Modular Port Adapter\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/1/1/2\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/1/1/3\", DESCR: \"10GBASE-ZR SFP+, SMF 80km\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/1/1/4\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/1/1/5\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/1/1/6\", DESCR: \"10GBASE-ZR SFP+, SMF 80km\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/1/1/7\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module 0/2/CPU0\", DESCR: \"160G Modular Linecard, Service Edge Optimized\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module 0/2/0\", DESCR: \"ASR 9000 8-port 10GE Modular Port Adapter\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/2/0/0\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/2/0/1\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/2/0/2\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/2/0/3\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/2/0/4\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/2/0/5\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/2/0/6\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/2/0/7\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module 0/3/CPU0\", DESCR: \"160G Modular Linecard, Service Edge Optimized\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module 0/3/0\", DESCR: \"ASR 9000 8-port 10GE Modular Port Adapter\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/3/0/0\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/3/0/1\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/3/0/2\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/3/0/3\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/3/0/4\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/3/0/5\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/3/0/6\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-CGD01-01.txt:NAME: \"module mau 0/3/0/7\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module 0/RSP0/CPU0\", DESCR: \"ASR9K Route Switch Processor with 440G/slot Fabric and 12GB\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module 0/RSP1/CPU0\", DESCR: \"ASR9K Route Switch Processor with 440G/slot Fabric and 12GB\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module 0/0/CPU0\", DESCR: \"160G Modular Linecard, Service Edge Optimized\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module 0/0/0\", DESCR: \"ASR 9000 8-port 10GE Modular Port Adapter\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/0/0\", DESCR: \"10GBASE-ZR SFP+, SMF 80km\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/0/1\", DESCR: \"10GBASE-ZR SFP+, SMF 80km\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/0/2\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/0/3\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/0/4\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/0/5\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/0/6\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/0/7\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module 0/0/1\", DESCR: \"ASR 9000 8-port 10GE Modular Port Adapter\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/1/0\", DESCR: \"10GBASE-ZR SFP+, SMF 80km\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/1/1\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/1/2\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/1/3\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/1/4\", DESCR: \"10GBASE-ZR SFP+, SMF 80km\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/1/5\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/1/6\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/0/1/7\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module 0/1/CPU0\", DESCR: \"160G Modular Linecard, Service Edge Optimized\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module 0/1/0\", DESCR: \"ASR 9000 8-port 10GE Modular Port Adapter\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/0/0\", DESCR: \"10GBASE-ZR SFP+, SMF 80km\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/0/1\", DESCR: \"10GBASE-ZR SFP+, SMF 80km\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/0/2\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/0/3\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/0/4\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/0/5\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/0/6\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/0/7\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module 0/1/1\", DESCR: \"ASR 9000 8-port 10GE Modular Port Adapter\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/1/0\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/1/1\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/1/2\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/1/3\", DESCR: \"10GBASE-ZR SFP+, SMF 80km\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/1/4\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/1/5\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/1/6\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-GDL01-01.txt:NAME: \"module mau 0/1/1/7\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module 0/RSP0/CPU0\", DESCR: \"ASR9K Route Switch Processor with 440G/slot Fabric and 12GB\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module 0/RSP1/CPU0\", DESCR: \"ASR9K Route Switch Processor with 440G/slot Fabric and 12GB\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module 0/0/CPU0\", DESCR: \"160G Modular Linecard, Service Edge Optimized\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module 0/0/0\", DESCR: \"ASR 9000 8-port 10GE Modular Port Adapter\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/0/0/0\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/0/0/1\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/0/0/2\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/0/0/3\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/0/0/4\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/0/0/5\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/0/0/6\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/0/0/7\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module 0/0/1\", DESCR: \"ASR 9000 8-port 10GE Modular Port Adapter\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/0/1/0\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/0/1/2\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/0/1/3\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/0/1/4\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/0/1/5\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/0/1/6\", DESCR: \"10GBASE-ER 1550nm SMF 40KM\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/0/1/7\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module 0/1/CPU0\", DESCR: \"160G Modular Linecard, Service Edge Optimized\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module 0/1/0\", DESCR: \"ASR 9000 8-port 10GE Modular Port Adapter\"\n"
"RMAGRJO-MRT01-01.txt:NAME: \"module mau 0/1/0/0\", DESCR: \"10GBASE-LR SFP+ Module for SMF\"\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")