const regex = /www\.hasbro\.com\/(.{1,10})\/\s?$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('www\\.hasbro\\.com\\\/(.{1,10})\\\/\\s?$', 'g')
const str = `https://www.hasbro.com/zh-hant-tw/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}