$re = '/\$\{(\w+)/m';
$str = 'whoad123@@${studentA.math1.math2}dsafddasfd${studentB.math2.math3}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);