re = /\$\{(\w+)/m
str = 'whoad123@@${studentA.math1.math2}dsafddasfd${studentB.math2.math3}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end