re = /^(?!.*PageView)fbq\('track.*\);$/m
str = 'fbq(\'track\'abc);
fbq(\'track\'PageView);
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end