$re = '/^([^:]*)[:]([^#]*)(?!line.*)/m';
$str = 'Sally: Hello there #line:34de2f
Bob: How are you today?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);