re = /^([^:]*)[:]([^#]*)(?!line.*)/m
str = 'Sally: Hello there #line:34de2f
Bob: How are you today?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end