import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:\\d{6} \\d{5}|[1-9]\\d{4} \\d{5}|[1-9]\\d{9}|\\d{11})\\b";
final String string = "1234567890\n"
+ "01234567890\n"
+ "12345 67890\n"
+ "012345 67890\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}