const regex = new RegExp('\\b(?:\\d{6} \\d{5}|[1-9]\\d{4} \\d{5}|[1-9]\\d{9}|\\d{11})\\b', 'gm')
const str = `1234567890
01234567890
12345 67890
012345 67890
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}