$re = '/[^a-zA-Z0-9;=-\\\\\\\\\/]/m';
$str = 'Bob%%0d%00d%0aa<script>alert(\'document.domain\')</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);