re = /[^a-zA-Z0-9;=-\\\\\/]/m
str = 'Bob%%0d%00d%0aa<script>alert(\'document.domain\')</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end