const regex = /\b([\"]*|[\> ]*|[\>]*$)(?!logo@2x\.png)(\w([\w\.]|[\w\-]|[\w\_])*@\w+\.[\w\.]+)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([\\"]*|[\\> ]*|[\\>]*$)(?!logo@2x\\.png)(\\w([\\w\\.]|[\\w\\-]|[\\w\\_])*@\\w+\\.[\\w\\.]+)\\b', 'gm')
const str = `logo@word.com
logo@2x.png
>test_yy@example.com< or
"a@b.com"
a.b.c@d.e.f.co
no.body@example.com
another.test.email@example.com
and.another.one@example.com.au
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}