import Foundation
let pattern = #"\b([\"]*|[\> ]*|[\>]*$)(?!logo@2x\.png)(\w([\w\.]|[\w\-]|[\w\_])*@\w+\.[\w\.]+)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
logo@word.com
logo@2x.png
>test_yy@example.com< or
"a@b.com"
a.b.c@d.e.f.co
no.body@example.com
another.test.email@example.com
and.another.one@example.com.au
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)