#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)#\s*master\s+([\s\S]+?)\s*#\s+osd"
Local $sString = "# version" & @CRLF & _
"# Betaflight / SPEEDYBEEF405V3 (SBF4) 4.3.2 Apr 7 2023 / 03:15:27 (f156481e9) MSP API: 1.44" & @CRLF & _
"" & @CRLF & _
"# start the command batch" & @CRLF & _
"batch start" & @CRLF & _
"" & @CRLF & _
"# master" & @CRLF & _
"set gyro_lpf1_static_hz = 0" & @CRLF & _
"set gyro_lpf2_static_hz = 300" & @CRLF & _
"set dyn_notch_q = 500" & @CRLF & _
"set dyn_notch_min_hz = 100" & @CRLF & _
"set dyn_notch_max_hz = 500" & @CRLF & _
"set gyro_lpf1_dyn_min_hz = 0" & @CRLF & _
"set gyro_lpf1_dyn_max_hz = 400" & @CRLF & _
"set mag_hardware = NONE" & @CRLF & _
"set rc_smoothing_auto_factor = 35" & @CRLF & _
"" & @CRLF & _
"# osd" & @CRLF & _
"set osd_vbat_pos = 471" & @CRLF & _
"set osd_rssi_pos = 449"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")