package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#\s*master\s+([\s\S]+?)\s*#\s+osd`)
var str = `# version
# Betaflight / SPEEDYBEEF405V3 (SBF4) 4.3.2 Apr 7 2023 / 03:15:27 (f156481e9) MSP API: 1.44
# start the command batch
batch start
# master
set gyro_lpf1_static_hz = 0
set gyro_lpf2_static_hz = 300
set dyn_notch_q = 500
set dyn_notch_min_hz = 100
set dyn_notch_max_hz = 500
set gyro_lpf1_dyn_min_hz = 0
set gyro_lpf1_dyn_max_hz = 400
set mag_hardware = NONE
set rc_smoothing_auto_factor = 35
# osd
set osd_vbat_pos = 471
set osd_rssi_pos = 449`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}