package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^( ?(-|\*|_) ?){3,}[ \t]*$`)
var str = `- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}