re = /^( ?(-|\*|_) ?){3,}[ \t]*$/m
str = '- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end