using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/(?:[^\/ ]*\/)*";
string input = @"junk before tag <img src=""https://somedomain.com/wp-content/uploads/2017/10/someimage.jpg"" alt="" />Random text after";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}