package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?:\/\/(?:[^\/ ]*\/)*`)
var str = `junk before tag <img src="https://somedomain.com/wp-content/uploads/2017/10/someimage.jpg" alt="" />Random text after`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}