use strict;
my $str = 'prefix a:77
prefix a:77 b:3.25 abc
prefix a:77 abc b:3.25 abc
prefix a:77 abc abc b:3.25 abc
prefix a:77 #$#^ #$1sfd b:3.25 abc';
my $regex = qr/.*a:([0-9]*).*?(?:(b:([0-9]*\.[0-9]*))|.)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}