# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*a:([0-9]*).*?(?:(b:([0-9]*\.[0-9]*))|.)*"
test_str = ("prefix a:77\n"
"prefix a:77 b:3.25 abc\n"
"prefix a:77 abc b:3.25 abc\n"
"prefix a:77 abc abc b:3.25 abc\n"
"prefix a:77 #$#^ #$1sfd b:3.25 abc")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.