#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\wàáâäãåąčćęèéêëėįìíîïłńòóôöõøùúûüųūÿýżźñçčšžÀÁÂÄÃÅĄĆČĖĘÈÉÊËÌÍÎÏĮŁŃÒÓÔÖÕØÙÚÛÜŲŪŸÝŻŹÑßÇŒÆČŠŽ∂ð']{6,20}$"
Local $sString = "Válidas" & @CRLF & _
"" & @CRLF & _
"AaaaaaaaBCCcc654_qq" & @CRLF & _
"1111s123AaBCcc654_qq" & @CRLF & _
"____ds4___xx" & @CRLF & _
"12345_123" & @CRLF & _
"" & @CRLF & _
"-Inválidas." & @CRLF & _
"asdmkk45hjsiwehsnasp21" & @CRLF & _
"12345-123 (tem hífen)" & @CRLF & _
"asdkdn 092834sdfdf (tem espaco em branco)" & @CRLF & _
"$123.0 (tem "$" e ".")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")