import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\wàáâäãåąčćęèéêëėįìíîïłńòóôöõøùúûüųūÿýżźñçčšžÀÁÂÄÃÅĄĆČĖĘÈÉÊËÌÍÎÏĮŁŃÒÓÔÖÕØÙÚÛÜŲŪŸÝŻŹÑßÇŒÆČŠŽ∂ð']{6,20}$";
final String string = "Válidas\n\n"
+ "AaaaaaaaBCCcc654_qq\n"
+ "1111s123AaBCcc654_qq\n"
+ "____ds4___xx\n"
+ "12345_123\n\n"
+ "-Inválidas.\n"
+ "asdmkk45hjsiwehsnasp21\n"
+ "12345-123 (tem hífen)\n"
+ "asdkdn 092834sdfdf (tem espaco em branco)\n"
+ "$123.0 (tem \"$\" e \".\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}