$re = '/(?:\G(?!\A)|{),?"\d+":\K(?<value>\d+)\b/m';
$str = '{"146":146,"547":547,"179":179,"79":79}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);