re = /(?:\G(?!\A)|{),?"\d+":\K(?<value>\d+)\b/m
str = '{"146":146,"547":547,"179":179,"79":79}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end